This article applies to:
- WebMarshal (versions 6.11 through 7.0)
Symptoms:
- Error in Proxy log: Connection pool size of 6000 exceeded
- Slow web page loading or failed loading
- High resource usage on WebMarshal server
Causes:
- This issue can be caused when WebSocket connections are not released and never time out.
- This issue has been observed more frequently in early 2018 and appears to be related to environmental changes on some third party servers hosting WebSocket services.
Resolution:
Upgrade to version 7.1 or above. This issue is resolved in 7.1 and later versions.
Workaround:
If you cannot upgrade immediately, you can apply a fix. This fix works with all supported WebMarshal versions (6.11 through 7.0). The "Connection Pool Size Exceeded Update" is available for download from the WebMarshal download page (login required).