Skip to main content

LevelBlue Completes Acquisition of Cybereason.  Learn More

LevelBlue Completes Acquisition of Cybereason.  Learn More

Services
Cyber Advisory
Managed Cloud Security
Data Security
Managed Detection & Response
Email Security
Managed Network Infrastructure Security
Exposure Management
Security Operations Platforms
Incident Readiness & Response
SpiderLabs Threat Intelligence
Solutions
BY TOPIC
Offensive Security
Solutions to maximize your security ROI
Operational Technology
End-to-end OT security
Microsoft Security
Unlock the full power of Microsoft Security
Securing the IoT Landscape
Test, monitor and secure network objects
Why LevelBlue
About Us
Awards and Accolades
LevelBlue SpiderLabs
LevelBlue Security Operations Platforms
Security Colony
Partners
Microsoft Security
Unlock the full power of Microsoft Security
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Loading...
Loading...

ERRMSG: Connection pool size of 6000 exceeded

Expand / Collapse


This article applies to:

  • WebMarshal (versions 6.11 through 7.0)

Symptoms:

  • Error in Proxy log: Connection pool size of 6000 exceeded
  • Slow web page loading or failed loading
  • High resource usage on WebMarshal server 

Causes:

  • This issue can be caused when WebSocket connections are not released and never time out.
  • This issue has been observed more frequently in early 2018 and appears to be related to environmental changes on some third party servers hosting WebSocket services.

Resolution:

Upgrade to version 7.1 or above. This issue is resolved in 7.1 and later versions.

Workaround:

If you cannot upgrade immediately, you can apply a fix. This fix works with all supported WebMarshal versions (6.11 through 7.0). The "Connection Pool Size Exceeded Update" is available for download from the WebMarshal download page (login required).


To contact LevelBlue about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.