This article applies to:
- Trustwave MailMarshal (SEG) 7.0 and above
- Trustwave ECM/MailMarshal Exchange 7.X
Symptoms:
- Messages queue in the "Incoming" queue folder
- No messages are processed by the Engine service
Causes:
- Windows Search is enabled on the processing node server.
- When the Windows Search service is enabled on SEG or ECM processing servers, it can lock files in the incoming queue folder.
- The Engine service is unable to retrieve or process the email from the incoming queue folder.
Resolution:
To resolve this issue, disable Windows Search on all SEG or ECM processing servers.
- Open the Windows Services control panel.
- Locate the service labelled "Windows Search."
- Stop and disable this service.
Alternatively you could add exclusions to the search service. Exclude all folders that must be excluded from virus scanning. See article Q10850.
Notes:
- The "Windows Search" service is not installed by default on Windows 2008 and 2012 servers.
- This issue could also affect the unpacking and quarantine folders, or any folder where files are frequently created, quickly accessed and deleted.