Transport Agent does not install under Exchange 2013 SP1


This article applies to:

  • Trustwave ECM/MailMarshal Exchange
  • Exchange 2013 SP1

Symptoms:

  • Attempting to install and enable the Agent for integration with Exchange
  • Error message: ServiceManager_SetAgentStatus Failed: No error message returned
  • Install log may show The TransportAgentFactory type must be the Microsoft .NET class type of the transport agent factory

Causes:

  • The issue is due to a problem with Exchange 2013 SP1. See Microsoft Knowledgebase article Q2938053.

Resolution:

  • On the Exchange server where the Agent is to be installed, apply the hotfix as described in the Microsoft article.
  • After the hotfix is applied, install and enable the ECM Agent. 

Notes:

Experience indicates a restart of the affected system is required in some cases after installing the Microsoft hotfix.


Last Modified 11/12/2014.
https://support.trustwave.com/kb/KnowledgebaseArticle20059.aspx