Skip to main content

LevelBlue Completes Acquisition of Cybereason.  Learn More

LevelBlue Completes Acquisition of Cybereason.  Learn More

Services
Cyber Advisory
Managed Cloud Security
Data Security
Managed Detection & Response
Email Security
Managed Network Infrastructure Security
Exposure Management
Security Operations Platforms
Incident Readiness & Response
SpiderLabs Threat Intelligence
Solutions
BY TOPIC
Offensive Security
Solutions to maximize your security ROI
Operational Technology
End-to-end OT security
Microsoft Security
Unlock the full power of Microsoft Security
Securing the IoT Landscape
Test, monitor and secure network objects
Why LevelBlue
About Us
Awards and Accolades
LevelBlue SpiderLabs
LevelBlue Security Operations Platforms
Security Colony
Partners
Microsoft Security
Unlock the full power of Microsoft Security
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Loading...
Loading...

PRB: Transport Agent does not install under Exchange 2013 SP1

Expand / Collapse


This article applies to:

  • Trustwave ECM/MailMarshal Exchange
  • Exchange 2013 SP1

Symptoms:

  • Attempting to install and enable the Agent for integration with Exchange
  • Error message: ServiceManager_SetAgentStatus Failed: No error message returned
  • Install log may show The TransportAgentFactory type must be the Microsoft .NET class type of the transport agent factory

Causes:

  • The issue is due to a problem with Exchange 2013 SP1. See Microsoft Knowledgebase article Q2938053.

Resolution:

  • On the Exchange server where the Agent is to be installed, apply the hotfix as described in the Microsoft article.
  • After the hotfix is applied, install and enable the ECM Agent. 

Notes:

Experience indicates a restart of the affected system is required in some cases after installing the Microsoft hotfix.


To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.