550 Unable to relay for
This article applies to:
Trustwave MailMarshal (SEG)
Symptoms:
An outbound message is not delivered to a remote recipient
The local sender may receive a non-delivery report
The MailMarshal Sender log shows an error response similar to the following:
RX: <550 5.7.1 Unable to relay for a@b.c>
Causes:
This error is not generated by MailMarshal and in almost every case the issue is not a MailMarshal issue.
The mail server that MailMarshal tries to send the message to is rejecting the mesage.
DNS Mail Exchanger or A records that are published for the recipient domain point to a server that does not accept mail for the domain.
Resolution:
Verify that MailMarshal does not have a custom routing configured for the recipient domain.
Contact the recipient organization to report the issue and find the acceptable domains.
Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle14338.aspx