This article applies to:
- Bitdefender for Marshal
- Sophos for Marshal
- Trustwave MailMarshal (SEG) 6.5
Symptoms:
- Email attachment names contain text outside of the English character sets
- Attachment names do not display correctly
- Email attachments fail to unpack with errors such as "Error in file type identification"
- Virus scanning fails with "unexpected error"
Causes:
- Regional Settings on the server (processing node) are set to a language other than English.
- File names with Unicode characters are not correctly handled by the named products when Regional Settings use extended characters.
Workaround:
To work around this issue, set the locale for the server to an English language locale (in an array, set the locale on all processing node servers). You can do one of the following:
- Log on to the server using an account such as Administrator. Use the Windows Regional and Language Options control panel to change the locale for the account, and then configure the MailMarshal services to run using that account. If you change the locale, you must restart the services to apply the change.
- Change the locale for service accounts:
- In Windows 2012, 2016 or 2019, set the locale on the Administrative tab of Region options. Restart the server to apply the change.
- In Windows Server 2008 or Windows Vista, use the "Copy to reserved accounts" function. Restart the server to apply the change.
- In Windows Server 2003 or Windows XP, log on as an administrator. Change the regional options for the account. Then, on the Advanced tab of Regional and Language Options, select the box under Default user account settings. Restart the server to apply the change to service accounts.
Notes:
- This issue applies to all versions of the named virus scanners.
- The issue does not affect basic attachment unpacking in supported versions of SEG.