Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

BUG: Files with Unicode names not processed correctly

Expand / Collapse


This article applies to:

  • Bitdefender for Marshal
  • Sophos for Marshal
  • Trustwave MailMarshal (SEG) 6.5

Symptoms:

  • Email attachment names contain text outside of the English character sets
  • Attachment names do not display correctly
  • Email attachments fail to unpack with errors such as "Error in file type identification"
  • Virus scanning fails with "unexpected error"

Causes:

  • Regional Settings on the server (processing node) are set to a language other than English.
  • File names with Unicode characters are not correctly handled by the named products when Regional Settings use extended characters.

Workaround:

To work around this issue, set the locale for the server to an English language locale (in an array, set the locale on all processing node servers). You can do one of the following:

  • Log on to the server using an account such as Administrator. Use the Windows Regional and Language Options control panel to change the locale for the account, and then configure the MailMarshal services to run using that account. If you change the locale, you must restart the services to apply the change.
  • Change the locale for service accounts:
    • In Windows 2012, 2016 or 2019, set the locale on the Administrative tab of Region options. Restart the server to apply the change.
    • In Windows Server 2008 or Windows Vista, use the "Copy to reserved accounts" function. Restart the server to apply the change.
    • In Windows Server 2003 or Windows XP, log on as an administrator. Change the regional options for the account. Then, on the Advanced tab of Regional and Language Options, select the box under Default user account settings. Restart the server to apply the change to service accounts.

Notes:

  • This issue applies to all versions of the named virus scanners.
  • The issue does not affect basic attachment unpacking in supported versions of SEG.

To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.