LDAP import from Lotus Domino does not retrieve some users


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave SPE Connector Agent
  • LDAP Connector
  • Lotus Domino

Symptoms:

  • Some users are not imported through the LDAP connector from Notes/Domino
  • Affected users have names that include accented characters such as ü

Causes:

  • SEG and Connector Agent LDAP connectors use LDAP version 2 by default. Some versions of Domino do not correctly return these characters through LDAP v2.

Resolution:

To resolve the issue, change the LDAP connector to use LDAP v3.

For Trustwave SEG:

  1. Open the SEG Configurator or Management Console.
  2. Expand Policy Elements > Connectors.
  3. Edit the affected connector. On the LDAP Server tab, select Version 3.
  4. Apply the change, and commit configuration changes.

For Trustwave SPE Connector Agent:

  1. Open the Connector Agent Configurator.
  2. From the tree, select the affected connector.
  3. On the Server Info tab, select Version 3.
  4. Apply the change.

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle12903.aspx