Digest messages not accepted by some mail systems due to UTF-7 encoding


This article applies to:

  • Trustwave MailMarshal (SEG) 
  • Trustwave ECM/MailMarshal Exchange 7.X
  • Message Digest functionality

Symptoms:

  • Some email servers do not accept MailMarshal digest messages for delivery
  • Some email clients do not properly render the content of MailMarshal digest messages

Causes:

  • Digest messages in the affected MailMarshal versions allow Unicode text in the body (subject lines of digested messages).
  • This enhancement allows users to view message subjects in non-european character sets including CJK (Chinese Traditional & Simplified, Japanese, Korean, and Korean EUC) as well as Vietnamese, Thai, UTF-7 and UTF-8 encoding.
  • Some software does not accept the encoding of these messages.

Workaround:

If you encounter this issue, you can apply the following Registry entry to revert to an earlier version of this functionality. Unicode characters will not be available. 

Note: This functionality was first made available in MailMarshal SMTP version 6.4.5.

  1. On the Array Manager, edit the Registry (MailMarshal (SEG) 10.X: this item is configured in the file arraymanager.config.json)
  2. Navigate to the Manager key:
    • In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Manager
    • 10.X: Add a value in the json file. See article Q10832.
    • For full details of the location for each product version, see article Q10832 or Q14003 (MailMarshal Exchange/ECM)
  3. Add a DWORD (integer) value DisableUTF7Digest in the registry or file, and set the value to 1.
  4. For version 8.X and below, commit configuration changes.
  5. Restart the Array Manager service.

    Warning: As always, take due care when editing the Registry. Make a backup before making changes.


Note: Only new digests will be generated without UTF-7 encoding. Existing digests are not affected.


Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle12131.aspx