This article applies to:
- Trustwave MailMarshal (SEG)
- Trustwave ECM/MailMarshal Exchange
Symptoms:
- Why can't I see all the emails in my archive folders?
Causes:
- In SEG 8.X and below, check the console preference Archive messages visible for (months).
- Messages might also not be visible if you have changed the location of the folder (typically, older messages would not be seen).
- This can also occur due to a SQL Express database that has exceeded its size limit, or to other database issues in some earlier versions of MailMarshal SMTP (new messages would not be seen).
Resolution:
If you have changed the location of folders, you must copy messages manually. To copy the old emails navigate to the original folder and transfer all the emails over to the new location. The old folder will be a folder with a GUID name.
Notes:
- For information about MailMarshal folder structure (GUID named and "symbolic" folders), see Trustwave Knowledgebase article Q10220.
- For information about database issues in earlier versions of MailMarshal SMTP, see Q10607.