Failed to query value 'Queues', 2 - The system can not find the file specified.


This article applies to:

  • Trustwave MailMarshal (SEG) 8.X and below
  • Trustwave ECM/MailMarshal Exchange 7.X

Symptoms

  • Error Message: Failed to query value 'Queues', 2 - The system can not find the file specified.
  • MailMarshal Engine will not start

Causes

  • This error indicates that a folder required by MailMarshal is not present in the expected location in the file system.
  • The error can occur after a MailMarshal node upgrade.
  • The error can occur after adding a node to an array.   

Resolution:

  • Restart the MailMarshal Controller.
  • If restarting the controller doesn't work, you can use the SEG Server Tool on each node to set the folder locations.

Older MailMarshal Versions

  • In versions that do not include the server tool, create or edit entries in the registry to locate the required folders. After creating the entries, commit MailMarshal configuration and restart MailMarshal services.
  • Create the values in the following location: {MailMarshal location}\Node\Directories
To determine the {MailMarshal location} in registry, and the default installation locations, see these articles:
  • Trustwave MailMarshal (SEG): Q10832
  • Trustwave ECM/MailMarshal Exchange: Q14003





Warning: Using the Registry Editor incorrectlycan cause serious problems that may require you to reinstall youroperating system. Trustwave cannot guarantee that problems resulting from theincorrect use of Registry Editor can be solved. Make sure that youback up your Registry prior to making any changes.

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11762.aspx