Error accessing Web Consoles after upgrading MailMarshal SMTP


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Web Components

Symptoms:

When attempting to access the AdminConsole (8.X and below) or SpamConsole, you receive an error similar to the following:

Server Error in '/AdminConsole' Application

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Access is denied: 'MMWebInterface'.

(You may also receive the generic Server Error message indicating that an error has occurred but error reporting is not configured)

Causes:

The account used as the identity by the Default Application Pool has insufficient privileges to complete your request. By default the Default App Pool uses an identity of "Network Service".  

Resolution:

In order to correct this error, do the following

IIS 7.X

  1. Open IIS Manager (Start | Control Panel | Administrative Tools | Internet Information Services (IIS) Manager).
  2. Expand the Default Web Site. Highlight the AdminConsole or SpamConsole virtual directory. On the Actions sidebar click Basic Settings.
    • Note the name of the application pool.
    • Click Cancel to exit.
    • By default AdminConsole and SpamConsole use the same application pool. You may want to verify this.
  3. Expand "Application Pools."
  4. Right-click the application pool noted above, and select Advanced Settings.
  5. Edit the Identity setting.
  6. Select the Built-in account "Local System" from the menu.
  7. Click OK.
  8. Repeat if required for another application pool.
  9. Restart the default web site.

IIS 6.0

  1. Open IIS Manager (Start | Settings | Control Panel | Administrative Tools | Internet Information Services (IIS) Manager).
  2. Expand "Application Pools."
  3. Right-click on "DefaultAppPool" and select "Properties."
  4. Select the "Identity" tab on the "DefaultAppPool Properties" window.
  5. Make sure "Predefined" is selected, and then select "Local System" from the menu.
  6. Click Apply, then OK.
  7. Restart the default web site.

IIS 5.0

  1. On the server where the web console resides, navigate to C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\CONFIG\
  2. Within this directory, use a text editor such as Notepad to open the file named machine.config
  3. Locate the section labeled "ProcessModel", and change userName="machine" to read userName="SYSTEM"
  4. Issue an iisreset command to restart IIS

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11487.aspx