Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

ERRMSG: Error accessing Web Consoles after upgrading MailMarshal SMTP

Expand / Collapse


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Web Components

Symptoms:

When attempting to access the AdminConsole (8.X and below) or SpamConsole, you receive an error similar to the following:

Server Error in '/AdminConsole' Application

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Access is denied: 'MMWebInterface'.

(You may also receive the generic Server Error message indicating that an error has occurred but error reporting is not configured)

Causes:

The account used as the identity by the Default Application Pool has insufficient privileges to complete your request. By default the Default App Pool uses an identity of "Network Service".  

Resolution:

In order to correct this error, do the following

IIS 7.X

  1. Open IIS Manager (Start | Control Panel | Administrative Tools | Internet Information Services (IIS) Manager).
  2. Expand the Default Web Site. Highlight the AdminConsole or SpamConsole virtual directory. On the Actions sidebar click Basic Settings.
    • Note the name of the application pool.
    • Click Cancel to exit.
    • By default AdminConsole and SpamConsole use the same application pool. You may want to verify this.
  3. Expand "Application Pools."
  4. Right-click the application pool noted above, and select Advanced Settings.
  5. Edit the Identity setting.
  6. Select the Built-in account "Local System" from the menu.
  7. Click OK.
  8. Repeat if required for another application pool.
  9. Restart the default web site.

IIS 6.0

  1. Open IIS Manager (Start | Settings | Control Panel | Administrative Tools | Internet Information Services (IIS) Manager).
  2. Expand "Application Pools."
  3. Right-click on "DefaultAppPool" and select "Properties."
  4. Select the "Identity" tab on the "DefaultAppPool Properties" window.
  5. Make sure "Predefined" is selected, and then select "Local System" from the menu.
  6. Click Apply, then OK.
  7. Restart the default web site.

IIS 5.0

  1. On the server where the web console resides, navigate to C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\CONFIG\
  2. Within this directory, use a text editor such as Notepad to open the file named machine.config
  3. Locate the section labeled "ProcessModel", and change userName="machine" to read userName="SYSTEM"
  4. Issue an iisreset command to restart IIS

To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.