Lea Service stops working after upgrading to Firewall Suite 4.0 or higher from an earlier version.


This article applies to:

  • WebTrends Firewall Suite 4.0
  • WebTrends Firewall Suite 4.1a

Symptoms:

  • Lea Service stops working after upgrading to Firewall Suite 4.0 or higher from an earlier version.
  • Syslog Service stops working after upgrading to Firewall Suite 4.0 or higher from an earlier version.

Changes Made:

Upgrade to Firewall Suite 4.0 or higher from an earlier version.

Causes:

If the Syslog service or LEA service are not stopped prior to upgrading you might encounter problems running these services after the upgrade. This is due to a registry key pointing to an incorrect location.

Information:

To change the registry setting, please follow these steps.

  1. Close any version of WebTrends or Firewall Suite software that is running.

  2. Open a command prompt, and access the directory where the earlier version of software is installed, and enter the following.

    WTSyslogServer.exe /remove <Enter>
    WTLeaService.exe /remove <Enter>

    This removes the old Microsoft Windows services from the registry.

  3. Start the new version of Firewall Suite.

  4. If there are profiles that use the LEA Service or the Syslog Server, Firewall Suite will automatically add the correct Microsoft Windows services. If this does not happen automatically however, they can be added manually, similar to the way the services were removed above from a command prompt.

    WTSyslogServer.exe /install <Enter>
    WTLeaService.exe /install <Enter>

  5. Exit and unload Firewall Suite.

  6. Using the Microsoft Windows Services Control Manager (control panel), check to see if these services are running. If they are, shut them down.

  7. Copy the old profiles containing the LEA/Syslog log files over to the new installation directory.

  8. Restart the services.

This article was previously published as:
NETIQKB4265

Last Modified 4/13/2006.
https://support.trustwave.com/kb/KnowledgebaseArticle10805.aspx