Unable to log into the Security Reporting Center interface.


This article applies to:

  • Security Reporting Center 2.x

Symptoms:

  • Unable to log into the Security Reporting Center interface.
  • Error: 'Login Failed. Please try again.'

Causes:

The authentication method for the user account being used to log into the interface was changed from NetIQ Authentication to System Authentication. Users are unable to log into Security Reporting Center, because there is no user matching the domain account in the database.

Information:

To resolve this issue, you must update the user name in the MySQL database to match the domain user name.  To do this, please follow the steps below:

  1. Connect to the Security Reporting Center MySql database using your tool of choice (see Notes for suggestions).

  2. Navigate to the wt_config database.

  3. Open the UserDefinitions table.

  4. Find the data record for the problem user account.

  5. Update the following fields:

    • login_name - Change to domain user name.
    • user_name - Change to domain user name.
    • specified_name - Clear this field so it is blank.
    • password_type - Change from wt to domain.

  6. Commit changes.

  7. Close the database editor.

  8. Restart all the Security Reporting Center related services.

  9. You should now be able to launch Security Reporting Center and log in using your domain account.

Notes:

A number of free GUI tools for MySQL administration are available. MySQL can also be administered from the command line.

The tool maintained by MySQL AB is available at the following URL: http://dev.mysql.com/downloads/gui-tools/

Note: SRC uses an older version of MySQL, so you may see a warning about version mismatch.

MySQL-Front, a well-known GUI tool, is no longer available.

 

This article was previously published as:

NETIQKB36522

Last Modified 5/23/2007.
https://support.trustwave.com/kb/KnowledgebaseArticle10780.aspx