This article applies to:
- Security Reporting Center 2.x
Question:
How do I change the IP address/hostname in Security Reporting Center?
Symptoms:
- Unable to logi n.
- Error: "An Internal Error has occurred."
Causes:
The IP address/Hostname of the computer where Security Reporting Center has been installed has changed.
Procedure:
To ensure that Security Reporting Center will continue to function properly after the IP/Hostname has changed, follow these steps:
- Stop all Marshal firewall reporting product services.
- Change the following entries in each of the following files. In the examples below SERVERNAME will be the current system name and is the entry that needs to be changed.
- <installdir>\modules\agent\agent.conf:
server = SERVERNAME
- <installdir>\common\apache\conf\httpd.conf:
ServerName SERVERNAME:9000
- <installdir>\common\uiserver\WEB-INF\web.xml:
<context-param>
<param-name>WtSchedJdbcUrl</param-name>
<param-value>jdbc:mysql://SERVERNAME:3306/wt_config</param-value>
</context-param>
- The wt_config DSN entry also needs to change. Please follow the steps below to change this setting:
- Click Start | Settings | Control Panel | Administrative Tools | Data Sources (ODBC).
- Select the System DSN tab.
- Highlight wt_config and click Configure.
- Change the IP/Host Name in the MySQL host (Name or IP) field.
- Click OK twice.
- Start all the services that you stopped.
You should now be able to log in to Security Reporting Center.
- This article was previously published as:
- NETIQKB35640