This article applies to:
- Security Reporting Center 2.0
- Security Reporting Center 2.1
Symptoms:
- Error: 'Java.lang.nullpointerexception.'
- User interface is very slow to respond.
Causes:
The problem is caused by the inability to connect to the Web based update page to check for a newer version of the product.
Information:
To get around the issue, the "Check for Update" feature will need to be disabled. To do this, follow the instructions below.
- Make a backup of the .\common\mysql\data directory.
- Within a command prompt, access the installation directory and go to .\common\mysql\bin.
- Access the database by typing:
mysql -u<username> -p<password>
(This is the username and password to connect to the database, not the UI.)
- Run the following query to obtain the ID of the "check for updates" flag:
Use wt_config
SELECT id
FROM option_tokens
WHERE key_name = 'updatesDisabled';
- Note the number returned.
- Run the following query to update the "check for updates" flag:
UPDATE option_confdata
SET data = '1'
WHERE key_id = 'XX'
(Where "XX" is replaced by the number returned from step 4.)
- Restart the "NetIQ - Tomcat" service and try to launch the application.
- This article was previously published as:
- NETIQKB36558