Loading...
Loading...

INFO: Supported Operating Systems and Prerequisite Versions for Trustwave SPE

Expand / Collapse


This article applies to:

  • Trustwave SEG Service Provider Edition

Question:

  • What are the supported operating systems for Trustwave SPE?
  • What version of SQL Server can be used with Trustwave SPE?
  • What versions of IIS and ASP.NET are supported by Trustwave SPE?
  • What versions of Internet Explorer are supported for Trustwave SPE?

Information:

The following table shows supported versions of operating systems and supporting software for Trustwave SEG Service Provider Edition (SPE).

This article applies only to the latest released version (as noted in the table). For information about earlier versions, see the documentation provided with each version.

For more detailed information please see the Trustwave SPE Administrator Guide.

Note: The operating system requirements apply to the main SPE server (Marshal Interface Agent server), Web Console servers, and all servers where SPE components are installed, including Trustwave SEG servers managed by SPE. For information about supported operating systems for Trustwave SEG, see the SEG Release Notes.

Key:

Symbol Meaning

Tested, Supported. No known issues

SPn

Minimum required service pack of the software

Qxxxxxx

Tested, Supported. See the KB article listed for known issues and workarounds

Not currently supported, obsolete, or known issues

Not specifically tested, but Trustwave plans to support the released version when it is available and has passed internal testing.

(blank)

Not applicable to this product

 

 

Trustwave SPE 4.2

Windows 2019

Windows 2016

Windows 2012 R2

Windows 2012

Windows 2008 R2 Microsoft terminated extended support on 14 January 2020.
Installation is not prevented but cannot be supported.


Windows 2008 or below

Windows 2008 R2 Core Edition
Windows 2012 / 2016 Core Edition

Windows XP
Windows Vista
Windows 7

SQL Express 
(Not supported in any version)

SQL 2019
(SQL Server Authentication or Mixed Mode is required)

SQL 2017
(SQL Server Authentication or Mixed Mode is required)

SQL 2016
(SQL Server Authentication or Mixed Mode is required)

SQL 2014
(SQL Server Authentication or Mixed Mode is required)

SQL 2012
(SQL Server Authentication or Mixed Mode is required)

SQL 2008 R2: Microsoft terminated support on 9 July 2019.

SQL 2008 or below

Internet Explorer 9.0 or below

Internet Explorer 10
(for Admin Console. The Admin Console requires Compatibility Mode.)

Internet Explorer 11
(for Admin Console. The Admin Console requires Compatibility Mode and may require the site to be placed in the Trusted Sites zone.)

IE, Firefox, Chrome, Safari (supported versions)
(for Customer Console and SQM)

  • Note: The Customer Console and SQM are tested for basic function using current versions of major browsers at the time of product release.
    • The "Scheduled Reports" page in SPE 4.2 is not functional in IE. Use another browser to access this page.

 

IIS 5.0, IIS 6.0

IIS 7.X

ASP.NET 3.5 SP1 and 4.7 (Required)

ADO/MDAC 2.5

ADO/MDAC 2.7 or above

Trustwave SEG 8.2.6 or above
(This is the only version supported for SPE 4.2.4. For details of the SEG version allowed with each SPE release, see article Q20963.)


To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.