DSM stopped launching after Java JRE upgrade.


This article applies to:

  • NAC 4.0.4
  • NAC 3.9.2

Symptoms:

  • After installing Java 7 update 45 or higher DSM (compliance scan) is not launching.

Causes:

  • New Java versions have an enhanced security model to make user systems less vulnerable to external exploits. Applications must be prepared in a specific way. 

Resolution:

Download and install the new version of the DSM Client application.

This application is available on the Trustwave Portal file library here (requires login).

Installation instructions:

  1. Move DSMClientSigned.zip to the NAC Server, to the root user's home directory
  2. On the server, Unzip the file:

    unzip DSMClientSigned.zip
  3. Run the deploy script

    ./deploy
  4. Wait for services to be restarted. Then test the DSM client scanning software.


Last Modified 9/15/2014.
https://support.trustwave.com/kb/KnowledgebaseArticle16696.aspx