Error: 'TNEF Attribute has invalid checksum' or similar


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange 7.X

Symptoms:

  • Error: 'TNEF Attribute has invalid checksum' or similar
  • Messages deadlettered

Causes:

  • MailMarshal performs checksum tests on any TNEF content it finds in messages. MailMarshal does this to verify integrity of the TNEF component.   

Available Change:

It is possible to disable these checksum tests if you wish to prevent these deadletters from occurring. Trustwave evaluates the level of risk associated with disabling the checksum test as low.

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you back up your Registry prior to making any changes.

  • In MailMarshal 10.0 and above, open the Management Console and navigate to Advanced Settings. Add a new value:
    • Name: Engine.TolerateBadTNEFChecksums
    • Type: Boolean
    • Value: True (selected)
  • In MailMarshal 8.X and below, open the Registry Editor on the Array Manager. Within the base registry key, navigate to \Default\Engine
    • In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\Engine
    • For information about the registry location for each version, see article Q10832.
    • Enter the value as a new DWORD value named TolerateBadTNEFChecksums with value 1.
  • Save your registry settings or configuration settings.
  • Commit the configuration changes and restart the MailMarshal Engine service on each node.

This article was previously published as:
NETIQKB41562

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10637.aspx