How do I change the IP address/hostname in Security Reporting Center?


This article applies to:

  • Security Reporting Center 2.x

Question:

How do I change the IP address/hostname in Security Reporting Center?

Symptoms:

  • Unable to logi n.
  • Error: "An Internal Error has occurred."

Causes:

The IP address/Hostname of the computer where Security Reporting Center has been installed has changed.

Procedure:

To ensure that Security Reporting Center will continue to function properly after the IP/Hostname has changed, follow these steps:

  1. Stop all Marshal firewall reporting product services.

  2. Change the following entries in each of the following files.  In the examples below SERVERNAME will be the current system name and is the entry that needs to be changed.
       

    1. <installdir>\modules\agent\agent.conf:

      server = SERVERNAME

    2. <installdir>\common\apache\conf\httpd.conf:

      ServerName SERVERNAME:9000

    3. <installdir>\common\uiserver\WEB-INF\web.xml:

      <context-param>
      <param-name>WtSchedJdbcUrl</param-name>
      <param-value>jdbc:mysql://SERVERNAME:3306/wt_config</param-value>
      </context-param>

  3. The wt_config DSN entry also needs to change.  Please follow the steps below to change this setting:

    1. Click Start | Settings | Control Panel | Administrative Tools | Data Sources (ODBC).

    2. Select the System DSN tab.

    3. Highlight wt_config and click Configure.

    4. Change the IP/Host Name in the MySQL host (Name or IP) field.

    5. Click OK twice.

  4. Start all the services that you stopped.

    You should now be able to log in to Security Reporting Center.

This article was previously published as:
NETIQKB35640

Last Modified 4/10/2006.
https://support.trustwave.com/kb/KnowledgebaseArticle10258.aspx