Skip to main content

LevelBlue Completes Acquisition of Cybereason.  Learn More

LevelBlue Completes Acquisition of Cybereason.  Learn More

Services
Cyber Advisory
Managed Cloud Security
Data Security
Managed Detection & Response
Email Security
Managed Network Infrastructure Security
Exposure Management
Security Operations Platforms
Incident Readiness & Response
SpiderLabs Threat Intelligence
Solutions
BY TOPIC
Offensive Security
Solutions to maximize your security ROI
Operational Technology
End-to-end OT security
Microsoft Security
Unlock the full power of Microsoft Security
Securing the IoT Landscape
Test, monitor and secure network objects
Why LevelBlue
About Us
Awards and Accolades
LevelBlue SpiderLabs
LevelBlue Security Operations Platforms
Security Colony
Partners
Microsoft Security
Unlock the full power of Microsoft Security
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Loading...
Loading...

ERRMSG: REST API: Access is denied

Expand / Collapse


This article applies to:

  • MailMarshal SEG REST API (8.X)
  • MailMarshal SPE access to SEG Array Managers (4.0 and above)

Symptoms:

  • Connecting to the SEG API
  • Entering credentials for connection to SEG in the SPE Admin Console Array page
  • Error message: Access is denied
  • Error message: The user has not been granted the requested logon type at this computer
  • Testing the credential in a browser returns HTTP 500 errors

Causes:

  • The credential being used does not have appropriate permissions on the server.
  • The credential must have Log on as a batch job permission (granted to Administrator accounts by default).
    • This permission can be set and overridden in GPO.
  • Accounts with permission to log on could also have limited access due to access control settings in the SEG Configurator.

Resolution:

Grant and verify the appropriate permissions for the account being used to connect.

Notes:

In MailMarshal (SEG) 10.0 and above, the API is secured using Bearer tokens derived from SEG Management Console credentials. Windows ACLs are not used. For details, see the MailMarshal (SEG) 10 API Handler listing attached to article 20867.


To contact LevelBlue about this article or to request support:


Rate this Article:
     

Related Articles



Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.