Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

PRB: Cannot view reports on screen

Expand / Collapse


This article applies to:

  • Marshal Reporting Console 2.5
    • This article does not apply to MRC 2.6
  • Microsoft Report Viewer Redistributable

Symptoms:

  • Cannot view generated reports on screen
  • Error on the MRC web page: A data source instance has not been supplied for the data source 'DB'.
  • Error on the MRC web page: The 'PageHeader' parameter is missing a value
  • Error on the MRC web page: Access to the path...is denied
  • Logging indicates that the reports are successfully generated. Reports can be viewed when sent by email.

Causes:

  • MRC installs the Report Viewer Redistributable 2008 R2 on the MRC server.
  • This release of the Report Viewer may not have appropriate settings for the latest Operating System versions or browser versions.

Resolution:

To resolve this issue you can update the Report Viewer Redistributable to the 2015 release.

  1. Obtain the Report Viewer 2015 Runtime from Microsoft.
  2. On the MRC server:
    • Use the Control Panel | Programs and Features cmdlet to remove the Report Viewer 2008 R2.
    • Install the Report Viewer 2015 Runtime.

Notes:

Also ensure that the MRC "Impersonate User" and the application pool identity have appropriate permissions.

 


To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.