Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

PRB: SQM Website loads slowly

Expand / Collapse


This article applies to:

  • Trustwave MailMarshal (SEG) Spam Quarantine Management website
  • Trustwave ECM/MailMarshal Exchange 7.X Quarantine Management website
  • Using Windows Authentication (NTLM)

Symptoms:

  • The Spam Quarantine Management site can be slow to load or might even time out.  
  • The symptoms can be intermittent.

Causes:

When using NTLM authentication with the SQM website, the Array Manager must interrogate a domain controller to verify that the user credentials being submitted are valid. The Array Manager uses DNS to determine which domain controller to communicate with. This is done with the use of DNS SRV records. The SRV record is used to map the name of a service (in this case, the LDAP service) to the DNS computer name of a server that offers that service.

You could encounter issues if the returned domain controller is:

  • Not local to the Array Manager server and has poor connectivity
  • Not accessible to the Array Manager - For example: blocked by a firewall
  • No longer available – For example: it has been decommissioned

The Array Manager log could contain entries similar to the example below.

<LDAP://domain:389/CN=Administrator,CN=Users,DC=local,DC=test> returned 0x8007203a after 45953ms

Resolution:

To resolve this problem, consider the following points:

  • Ensure that the DNS records reflect the current environment.
  • Check on all DNS servers that the SRV records are created in the following location:

    Forward Lookups -> <Domain> -> _tcp -> _ldap

  • Ensure that any domain controller that cannot be reached from the Array Manager, or no longer exists, is removed from the DNS entry (or has reduced priority).
  • Change the priority of the SRV records in DNS to ensure that the local domain controller for the Array Manager has the highest priority.

You could also choose to use the email address and password authentication mechanism for the SQM/QM websites. However changing mechanisms on a production system is complex.


To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.