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PRB: Reply to message release email fails to release the message

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This article applies to:

  • Trustwave MailMarshal (SEG)

Problem:

  • Sometimes when users immediately reply to a message release email, the reply fails to release the held email. 
  • If they try again or wait a minute before replying to the message release email then it succeeds and releases the email.

Cause:

  • The original email record is not yet inserted to the database when the user reply is received and processed.
    • Database record insertion is batched for efficiency, and may be delayed a few minutes.
    • Each release request is processed instantly.

Workaround:

  • User education may be sufficient to resolve any complaints about this issue.

  • In SEG/MailMarshal SMTP 6.8.2 and above, it is possible to delay the processing of the user release request. This can be done by adding a rule that uses the Hold action, above the "User Message Release" rule. 
    • Note that this delay will apply to ALL release requests and could cause equal or greater user confusion. Use the minimum possible delay.

  • The new rule can be named "Delay User Message Release" and it should look similar to the screenshot below.
  • Place the rule immediately above the existing rule that processes Message Release requests.
  • Remember to use the "addressed to" address that is used to submit your message release requests.



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