Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

HOWTO: Allowing Office to retrieve content from Microsoft via SWG

Expand / Collapse


Description:
An Identification Policy exception might be necessary on Secure Web Gateway (SWG) appliances in order to enable Office to download supplemental content from Microsoft.

Symptoms:
Although some clipart and templates are included with Office, much more is available as part of Microsoft’s online web collections.  Users might find that they are unable to access this online content from within Office applications.  When the administrator reviews the Web Log details that are related to these transactions, the following Identification Status is sometimes observed on the Policy Enforcement tab:

Error during authentication handshake

Cause:
Some Office installations have restrictions on proxy authentication.  For example, most Office 2003 installations will not authenticate when a proxy is deployed transparently (including WCCP installations).  This can prevent users from being able to retrieve supplemental Microsoft Office content.

Solution:
If users are unable to download supplemental Office content from Microsoft, please follow the steps below to add an exception to the SWG appliance’s Identification Policy.  This procedure will work for built-in and custom Identification Policies in which the Exclude by Headers list serves as an exception condition.  If using a custom Identification Policy that does not utilize this Header Fields list, please add it as a condition to the rule that performs authentication and select “Everything except for the items selected below” in the Applies to field.

  1. Navigate to Policies -> Condition Settings -> Header Fields.
  2. Select the Exclude by Headers list.
  3. Click the Edit button.
  4. Click the green + button to add a new list entry.
  5. In the Header Name field, type:

    Host
  6. In the Condition field, select Regular Expression.
  7. In the Header Value field, type:

    .*office(images)?.microsoft.com

    The entry should appear as it does in the screenshot below:


  8. Click the Save button.
  9. Commit the changes.

Please give the system ample time to finish committing before testing the change.

Software Versions:
9.x


To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.