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PRB: Old engine file can't be deleted after engine update

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This article applies to:

  • McAfee for Marshal 6.X
  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange
  • WebMarshal

Symptoms:

  • After the McAfee Engine is updated, the previous version of the file Mcscan32.dll cannot be deleted.

Causes:

  • When McAfee for Marshal updates the McAfee scanning engine, the new version of the engine DLL is placed in a new directory. The old file remains in place.
  • The MailMarshal or WebMarshal Engine and other services use the new McAfee engine, but they may continue to hold a lock on the old file.

Resolution:

It is generally not necessary to take any action. The file will be removed later.

If you want to delete the old McAfee engine file and it is locked, restart Marshal services as necessary using the Windows Services control panel on the server.

  • Trustwave MailMarshal (SEG) or MailMarshal Exchange Engine and Controller services
  • WebMarshal Engine, Controller, Array Manager, and/or Node Controller services (depending on version and server role)

To contact Trustwave about this article or to request support:


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