Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

PRB: SQL Express Event logs "WebMarshal database starting up" constantly

Expand / Collapse


This article applies to:

  • WebMarshal
  • Trustwave MailMarshal (SEG)
  • SQL Express

Symptoms:

  • The following event is logged to the Windows event viewer application log repeatedly (once a minute or more):

    Event Type: Information
    Event Source: MSSQLSERVER
    Event ID: 17137
    Description: Starting up database 'WebMarshal'.

  • Messages similar to the following are logged in SQL logs: SQL Server has encountered 2 occurrence(s) of cachestore flush

Causes:

  • These messages are logged as a result of the database autoclose feature in SQL being turned on for the WebMarshal or MailMarshal database.
  • For more information on the SQL Auto-Close feature, see the following from MSDN:
    http://msdn2.microsoft.com/en-us/library/ms190249.aspx

Resolution:

Disable the autoclose feature for the WebMarshal or MailMarshal database.

Trustwave recommends use of SQL Management Studio. This is free software available from Microsoft.

SQL Management Studio

  1. Open SQL Management Studio and connect to the instance that hosts the WebMarshal database.
  2. In the left pane expand Databases, right-click the WebMarshal database, and select Properties.
  3. From the Properties window, select Options.
  4. Under the heading Automatic, change  "Auto Close" from True to False.
  5. Click OK to apply the change.

SQL Query

If you do not have SQL Management Studio installed, the same can be accomplished by running the following SQL query:

ALTER DATABASE [WebMarshal] SET AUTO_CLOSE OFF WITH NO_WAIT

  • Replace "WebMarshal" in the above line with the appropriate name for your WebMarshal or MailMarshal logging database (keep the brackets).

Notes:

  • The logged event is informational only and does not indicate an error. The default behavior in some versions of SQL Express is to enable autoclose for databases. This behavior allows database files to be manipulated outside the SQL framework. For WebMarshal or MailMarshal databases, disabling autoclose can improve performance.
  • This issue has been corrected for new and upgraded databases in current versions of MailMarshal and WebMarshal.

To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.