Skip to main content

LevelBlue Completes Acquisition of Cybereason.  Learn More

LevelBlue Completes Acquisition of Cybereason.  Learn More

Services
Cyber Advisory
Managed Cloud Security
Data Security
Managed Detection & Response
Email Security
Managed Network Infrastructure Security
Exposure Management
Security Operations Platforms
Incident Readiness & Response
SpiderLabs Threat Intelligence
Solutions
BY TOPIC
Offensive Security
Solutions to maximize your security ROI
Operational Technology
End-to-end OT security
Microsoft Security
Unlock the full power of Microsoft Security
Securing the IoT Landscape
Test, monitor and secure network objects
Why LevelBlue
About Us
Awards and Accolades
LevelBlue SpiderLabs
LevelBlue Security Operations Platforms
Security Colony
Partners
Microsoft Security
Unlock the full power of Microsoft Security
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Loading...
Loading...

ERRMSG: Error Message: Null (Automatic message release fails)

Expand / Collapse


This article applies to:

    • Trustwave MailMarshal (SEG)
    • Windows 2003 and above

    Symptoms:

    • Error Message: Null (Automatic message release fails)

    Causes:

    • The MailMarshal Engine service is running under a user account that does not have the correct permissions required to carry out the function. 

    Resolution:

    Use an account that can be authenticated by the Array Manager and that has permission to release the messages from the folders.

    To set permissions on the folders used by MailMarshal SMTP:

    SEG 8.X and below

    1. In the MailMarshal Configurator, right click a folder and select Properties.
    2. Click the Security tab and set the security settings for the folder. Click OK.

      • Note: If you want to change the settings for all the folders, click on Default Folder Security and set the Permissions. Within each folder check the Override default folder security box on the security tab to override the Default Folder Security settings.
    3. Click Tools and select MailMarshal Properties.
    4. Select Console Security and select the account you want to use. Ensure Console and Folder Connect has a check in the Allow box.

    MailMarshal (SEG) 10.0 and above

    Ensure that the account used to run the Array Manager service has permission on the folders. This will be true by default (Array Manager runs as Local System by default).

    To allow External Command access to the messages:

    Current Versions:

    To resolve the issue set parameters of the Message Release external command.

    • Message Release works using a MailMarshal external command. The parameters of the command allow you to set the credentials for Message Release explicitly. These parameters must be accepted by the Array Manager server.

    See the User Guide and the following Trustwave Knowledgebase article for more information:

    • Q10466 How do I set up automatic message release in MailMarshal?

    6.1.4 and below:

    To resolve the issue change the account the MailMarshal Engine is running under.

    1. On the machine where MailMarshal is installed open Services.msc.
    2. Right click on the MailMarshal Engine service and select Properties.
    3. Select the Log On tab and select the This account radio button. Enter the credentials of a user that has sufficient rights to carry out the function. Click OK.  

    To contact Trustwave about this article or to request support:


    Rate this Article:
         

    Add Your Comments


    Comment submission is disabled for anonymous users.
    Please send feedback to Trustwave Technical Support or the Webmaster
    .