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ERRMSG: Cannot connect to Array Manager. Server with ID 1 does not exist.

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This article applies to:

  • Trustwave MailMarshal (SEG) 
  • Trustwave ECM/MailMarshal Exchange 7.X

Symptoms:

  • Error: Cannot connect to Array Manager. Server with ID 1 does not exist.

Causes:

  • The Node ID in the SQL database and the Node ID in the registry do not match. 
  • One possible cause is that the MailMarshal database has been re-created and the node has not been re-joined to the array.

Resolution:

WARNING: Before taking any steps, consider why and how the Node ID changed. The solution below assumes that you have intentionally re-created the database.

If necessary, contact Technical Support for assistance.

 

You can restore the connection by using the MailMarshal Server Tool to rejoin the node to the array.

Note: If your installation has more than one email processing server in an array, perform this action on each processing server.

MailMarshal SMTP, MailMarshal Exchange 7.X:

  1. On the machine where MailMarshal is installed, click Start and browse to the MailMarshal Server Tool.
  2. Select the Node > Array item.
  3. Specify the array and select Join this array. Click Apply and enter the Username, Password and Domain details for the Array Manager (use an account with the MailMarshal permission to join nodes).
  4. Restart services as prompted.
  5. Commit the configuration.

Note:

  • After you re-join a node to the array with a different node ID, quarantined email on the node will not be available for search in the Console. You can restore mail to visibility by renaming mail files and running the Quarantine Sync tool. See the "Server ID differs" steps in Trustwave Knowledgebase article Q10412
  • However, if you re-created a database because the old database exceeded the database size limit for SQL Express, you should not sync all messages, because this is likely to cause the size to be exceeded again.

 


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