This article applies to:
- Trustwave MailMarshal (SEG)
Symptoms:
Event ID: 3001
Type: Error
Source: MMReceiver
Description: Receiver Static Configuration Error. No Valid Configuration Available.
Causes:
This event is raised at service startup whenever the configuration contains an invalid entry that would otherwise be used by the MailMarshal SMTP Receiver service.
To determine the source of the issue, check the MailMarshal service text logs. The event will be followed by descriptive text indicating the rule or configuration setting that is incorrect. Use the MailMarshal Configurator/Management Console to investigate and correct the problem item.
This is a generic error, so there is no single way of repairing the problem. However, this issue is typically the result of one of the following:
- Editing the registry or advanced settings outside the GUI.
- A bad entry or error in user groups. In particular, check for rules that use imported (LDAP or AD) user groups, where the imported group may have been deleted at the source. Trustwave recommends that you do not use imported groups directly in rules. Instead, nest the group in a MailMarshal group.
Notes:
For more information see the following Trustwave Knowledgebase article:
- Q10630: MailMarshal services will not start.