This article applies to:
- Trustwave MailMarshal (SEG)
Symptoms:
Event ID: 2504
Type: Warning
Source: MMSender
Description: Protocol error
Causes:
The MailMarshal SMTP Sender service received a response other than "success" from a remote host during email sending.
This event occurs if the remote host replies with a 4xx or 5xx series status code to one of the MailMarshal Sender's commands.
More Info:
These responses could include 4xx series ("temporary failure") and 5xx series ("permanent failure").
- In most cases of 4xx response, the MailMarshal Sender will try again later.
- In most cases of 5xx response, no retry is possible and the message will never be delivered. In certain cases, the MailMarshal Sender will attempt to find a suitable alternative (such as attempting HELO if the remote hosts responds to EHLO with "500 - Command Unrecognized").
For more information on SMTP response codes, see: Q10837: What are the SMTP Reply Codes?
Full details on SMTP codes can be found in section 4 of Internet RFC 821/2821.
Why was the message rejected?
These errors can indicate many different conditions. For instance, the recipient's mailbox may be full, or the remote server may be rejecting email from your domain for policy reasons. Check the MailMarshal Sender text log for details of the exact message returned by the remote server.
If the explanatory text of the message does not give enough information, the only sure way to determine why a remote server rejects email is to contact the server administrator.