Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

ERRMSG: 2504 - Protocol error (MMSender warnings)

Expand / Collapse


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

Event ID: 2504
Type: Warning
Source: MMSender
Description: Protocol error

Causes:

The MailMarshal SMTP Sender service received a response other than "success" from a remote host during email sending.

This event occurs if the remote host replies with a 4xx or 5xx series status code to one of the MailMarshal Sender's commands.

More Info:

These responses could include 4xx series ("temporary failure") and 5xx series ("permanent failure").

  • In most cases of 4xx response, the MailMarshal Sender will try again later.
  • In most cases of 5xx response, no retry is possible and the message will never be delivered. In certain cases, the MailMarshal Sender will attempt to find a suitable alternative (such as attempting HELO if the remote hosts responds to EHLO with "500 - Command Unrecognized").

For more information on SMTP response codes, see: Q10837: What are the SMTP Reply Codes?

Full details on SMTP codes can be found in section 4 of Internet RFC 821/2821.

Why was the message rejected?

These errors can indicate many different conditions. For instance, the recipient's mailbox may be full, or the remote server may be rejecting email from your domain for policy reasons. Check the MailMarshal Sender text log for details of the exact message returned by the remote server.

If the explanatory text of the message does not give enough information, the only sure way to determine why a remote server rejects email is to contact the server administrator.


To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.