This article applies to:
- Trustwave MailMarshal (SEG)
Symptoms:
Event ID: 2503
Type: Warning
Source: MMSender
Description: Network transport error
Causes:
The remote host responded to a SMTP request from the MailMarshal SMTP Sender in an unexpected manner, or the connection was terminated without warning.
The possible causes of transport errors include:
- A misconfigured device such as a firewall or intermediate router
- Port-blocking, anti-virus software
- SMTP proxy firewall
- Rarely, a problem with the TCP subsystem on the MailMarshal server
The cause of this error is generally not the MailMarshal software. MailMarshal is only reporting the error.
More Info:
When communicating with a remote host, the MailMarshal Sender expects proper SMTP responses to the commands it issues.
If the remote host closes a connection without sending any prior indication, or the network socket is terminated unexpectedly, this error is logged.
Generally the detailed information on this event (in the MailMarshal text logs) shows a Winsock error, indicative of a general network error beyond the scope of MailMarshal. This event is tagged by MailMarshal as an error of type "SMTPSendAndExpect".