Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Trustwave and Cybereason Merge to Form Global MDR Powerhouse for Unparalleled Cybersecurity Value. Learn More

Services
Managed Detection & Response

Eliminate active threats with 24/7 threat detection, investigation, and response.

Co-Managed SOC (SIEM)

Maximize your SIEM investment, stop alert fatigue, and enhance your team with hybrid security operations support.

Advisory & Diagnostics

Advance your cybersecurity program and get expert guidance where you need it most.

Penetration Testing

Test your physical locations and IT infrastructure to shore up weaknesses before exploitation.

Database Security

Prevent unauthorized access and exceed compliance requirements.

Email Security

Stop email threats others miss and secure your organization against the #1 ransomware attack vector.

Digital Forensics & Incident Response

Prepare for the inevitable with 24/7 global breach response in-region and available on-site.

Firewall & Technology Management

Mitigate risk of a cyberattack with 24/7 incident and health monitoring and the latest threat intelligence.

Solutions
BY TOPIC
Microsoft Security
Unlock the full power of Microsoft Security
Offensive Security
Solutions to maximize your security ROI
Rapidly Secure New Environments
Security for rapid response situations
Securing the Cloud
Safely navigate and stay protected
Securing the IoT Landscape
Test, monitor and secure network objects
Why Trustwave
About Us
Awards and Accolades
Trustwave SpiderLabs Team
Trustwave Fusion Security Operations Platform
Trustwave Security Colony
Partners
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Trustwave PartnerOne Program
Join forces with Trustwave to protect against the most advance cybersecurity threats
Loading...
Loading...

PRB: Exchange or Domino server becomes unresponsive when receiving email from MailMarshal

Expand / Collapse


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Exchange or Domino server becomes unresponsive when receiving email from MailMarshal

Causes:

One issue that has historically caused issues on Exchange or Domino servers, whereby their SMTP services become unresponsive, is email traffic containing Bare Line Feeds.

A Bare Line Feed is a linefeed without a preceding carriage return. For more information view the following Web page:

http://cr.yp.to/docs/smtplf.html

Typically Bare Line Feeds are frequently found in Spam messages, and are rarely found in legitimate messages.  

This is not a new issue with Exchange or Domino. Given the nature of the problem, it appears at first glance to be caused by MailMarshal. Here is how MailMarshal appears guilty: you don't notice the problem until you put a mail relay (MailMarshal) in front of your existing mail server. Bare Line Feeds cause the threads being used between MailMarshal and your mail server to temporarily hang, and eventually time out. Without a mail relay you would only intermittently see the single thread fail between your mail server and the remote Spam source - thus you might never notice the problem.  However, if MailMarshal passes a large volume of Bare Line Feed messages through to your server simultaneously, it can effectively cause all threads on your mail server to temporarily hang.

 

Information:

By default MailMarshal accepts and ignores Bare Line Feeds. It is a good idea to either reject or fix bare line feeds at the MailMarshal Receiver. You should consider rejecting such messages outright given that they are in breach of RFC standards, and that they are typically associated with Spam messages. 

MailMarshal allows you to Block, Fix or Ignore bare line feeds (see Array Properties | Receiver | Advanced)

See the following Trustwave Knowledgebase article for more information on configuring MailMarshal to handle Bare Line Feeds.

  • Q10016 : "Bare carriage returns and bare linefeeds are technically not allowed in e-mail messages." 

This article was previously published as:
NETIQKB45726

 


To contact Trustwave about this article or to request support:


Rate this Article:
     
Tags:

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.