This article applies to:
- Security Reporting Center 2.x
- SurfControl
Symptoms:
- Error occurs when running proxy reports in Security Reporting Center.
- Error: 'CAT_ERROR_LICENSE_EXPIRED.'
- Proxy reports finish, but each profile's status indicates that the analysis finished with errors.
Causes:
This issue is caused by a problem with the Internet connection to the SurfControl web site, which validates the license during the profile analysis. The connection problem could be a failed Internet connection, or because the Internet is accessed through a web proxy server.
Information:
To determine if Internet connectivity problems are causing this issue, verify that the following machines are able to to access the SurfControl web site (listsrv.surfcontrol.com):
- The Security Reporting Center (SRC) machine itself
- Any other firewalls/proxy servers that are present between the SRC machine and the Internet
The web site, listsrv.surfcontrol.com, is where SRC validates the SurfControl database license, and also obtains the SurfControl database, which is used to populate SRC reports with URL categorization data.
To test connectivity to the listsrv.surfcontrol.com site, use the ping
or tracert
commands from the SRC machine to pinpoint any communication failures.
If the network uses a web proxy server to access the Internet, this issue may be resolved by adding the network's web proxy information to SRC by following these steps:
- On the left side of the SRC interface window, click the Administration link.
- Beneath the Administration menu, click the Options link. The Options menu will be presented.
- In the Options menu, click the link labeled Access to Internet. The settings screen appears.
- In the appropriate fields, enter the information for your web proxy server.
- When finished, click the Save button at the bottom of the Access to Internet settings window.
If a proxy server is in use and requires authentication, Security Reporting Center will only be able to use the proxy server if the authentication is set to either Basic or NTLM.
After you have configured your proxy server and have verified that Security Reporting Center can access listsrv.surfcontrol.com, try running the analysis again.
Note: This error can also be avoided by disabling URL categorization from within the profile. The URL Categorization sections of the report will not appear, but this will also prevent the error from being generated because the module is not loading.
- This article was previously published as:
- NETIQKB37416