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ERRMSG: Error: "java.lang.OutOfMemory"

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This article applies to:

  • Firewall Suite 4.1x
  • Security Reporting Center 2.X

Symptoms:

  • Error: "java.lang.OutOfMemory"
  • Out of memory errors are received when trying to view reports.

Causes:

The Java component does not allocating enough memory for reports with large amounts of data to load successfully.

Information:

For the report to display successfully, allocate more memory to Java. To do this please follow the steps below:

Important Note! Before making any changes, please make a backup of your registry.


Allocating Java memory on Windows:

  1. Open the Registry Editor by running the regedit command.

  2. Navigate to the following entry:

    HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/NetIQTomcatService/Parameters

  3. Add two new strings:

    • JVM Option Number 2
      value: -Xms10M

    • JVM Option Number 3
      value: -Xmx500M

  4. Change the "JVM Option Count" parameter from 2 to 4, because we have added two new parameters. Without making this change, the memory will not be affected.
  5. Restart the NetIQ Apache and NetIQ Tomcat services in Service Control Manager.

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your Registry prior to making any changes.

This article was previously published as:
NETIQKB35391

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