IIS Error 500.30 returned by MailMarshal (SEG) 10.X Configuration Service website


This article applies to:

  • Trustwave MailMarshal (SEG) 10.X
  • Configuration Service website

Symptoms:

  • After upgrade from 8.X, the Configuration Service website does not start and returns IIS error: 500.30 ANCM In-Process Start Failure

Causes:

  • This issue can be caused if the Configuration service cannot connect to the SQL database (default database name MailMarshalConfigService)
  • Note that error 500.19 has a different cause - see linked article below

Resolution:

  1. Run the MailMarshal Config Service Admin Tool
  2. On the Database tab:
    • If the connection is using the IIS application pool account, the SQL Server name must be Localhost (it cannot be the local server name or IP address).
    • If the connection is not using the IIS application pool account, enter credentials with full permission over the configured database. If possible, use a credential with System Administrator permission temporarily. 
  3. Restart IIS.
  4. Attempt to log in to the Management Console.

If you can log in you may be presented with the initial configuration wizard. In that case (assuming this was an upgrade from 8.X), do not proceed with the wizard.

To import the configuration that was automatically converted by upgrade:

  1. Note the MailMarshal user name and password created by the upgrade (defaults to admin/admin)
  2. From a command prompt, navigate to the MailMarshal install folder. 
  3. Run the following command:
    mmexportcfg -i -u admin -p adminpwd -f temp\seg10convertedconfig.zip
    • Substitute the username and password that you entered in the upgrade installer.
    • For details of mmexportcfg parameters see the User Guide.
  4. Start MailMarshal services.

Last Modified 9/7/2021.
https://support.trustwave.com/kb/KnowledgebaseArticle21168.aspx