This article applies to:
- Trustwave SEG
- (note changes at 8.1 and 8.2)
- WebMarshal
Symptoms:
- Cannot connect to SQL database
- Error logged: Database error: 0x80004005 - [DBNETLIB][ConnectionOpen (SECCreateCredentials()).]SSL Security error
Causes:
- SEG does not connect by default to SQL Server if TLS 1.2 is required by the SQL server, but an option is available in version 8.1 and above to enable this function.
- WebMarshal does not connect by default to SQL Server if TLS 1.2 is required, but an option is available in version 7.1 and above to enable this function.
Workaround:
Enable TLS 1.1 connectivity at the SQL Server.
Resolution:
- This issue is resolved in WebMarshal 7.1. See the related article linked below.
- This issue is resolved in SEG 8.1. See the related article linked below.
- In the above versions, customers have the option to use the recently released Microsoft OLE DB Driver that supports TLS 1.2.
- From SEG 8.2, the included default database provider driver is MSOLEDBSQL (supporting TLS v1.2 secured connections).