Engine behind, sleeping


This article applies to:

  • Trustwave SEG
  • This behavior may be more visible in version 8.0 and above

Symptoms:

  • Information logged in Receiver text log: Engine behind nn seconds, sleeping for nnnn

Causes:

  • This message is logged by a function that checks for high load.
  • The check is based on the last message processed by the Engine.
  • On a very lightly loaded system (only a few messages processed per minute), you might also see this message. The Engine can generally process between 20 and 40 messages per second, on average, depending on available resource.

Resolution:

In most cases you can safely ignore this log message.

  • To check whether messages are waiting for the Engine, check the folder Queues\Incoming within the SEG installation.
  • If you constantly see a large number of queued messages that is never reduced this may indicate under-resourcing of the server.
    • In this case, you should consider adding resource to the server or adding additional processing servers.
  • For further assistance with server resourcing, see the recommendations in the User Guide, or contact Trustwave support.

Trustwave plans to improve the behavior of this check on lightly loaded systems in a future release of SEG.


Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle20971.aspx