This article applies to:
- Trustwave SEG
- Upgrading an installation
- Automatically upgrading a node from the Array Manager
Symptoms:
- Upgrade fails
- Error message: Error opening Trustwave SEG registry key. Failed to query value 'CurrentConfig', 2
- Running Windows Programs and Features shows the message: There is a problem removing this software. Would you like to remove it from the list?
Cause:
This error on upgrade can be caused by the removal of the InstallShield directory which stores the data about previous installations (by default, C:\Program Files (x86)\InstallShield Installation Information), or the SEG specific subdirectory in this directory.
"System cleanup" applications might remove this directory or you might have removed it by mistake.
Solution:
Run the installer for the exact version of SEG that is already installed (such as 8.0.4.10434), and "install" it with the same options and modules. This process will re-create the uninstall information. After completing this process, you will be able to upgrade.
Notes:
- Removal of the InstallShield directory does not affect SEG functionality.
- Re-installing does not affect existing logs, quarantine folders, or any other files that were changed since the previous installation.