Could not upgrade the Trustwave SEG Database


This article applies to:

  • Trustwave SEG
  • Upgrading to a new version on an Array Manager or standalone server
  • The Database Operational User has minimum privileges
  • The Windows account that was logged in does not have administrative privilege on the SQL database
  • When prompted for an administrative account, you entered a user with privilege lower than Sysadmin

Symptoms:

  • Error message: Could not upgrade the Trustwave SEG Database
  • Error message: User does not have permission to perform this action
  • SEG Array Manager will not start after upgrade

Causes:

  • Database upgrade requires you to use an administrative account with Sysadmin privilege (such as SA) if the Operational User is not DB Owner.
  • The required permission is not enforced by the installation wizard.

Resolution:

To resolve this issue:

  1. Cancel the upgrade installation.
  2. After exiting the installer, do not attempt to start any SEG services.
  3. Re-run the upgrade installation. When prompted, enter a database administrative account with Sysadmin privilege.
    • Note: This credential is used only for the upgrade and is not stored.

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle20594.aspx