Error in file type identification


This article applies to:

  • Trustwave SEG

Symptoms:

  • Error in Engine log: DL44000: Unexpected error unpacking message: Error in file type identification
  • Sample of error:
    9672 17:11:14.652 DL44000: Unexpected error unpacking message - D:\Marshal\Queues\Incoming\BXXXXXXXXXXXX.000000000001.0005.mml
    Error in file type identification - D:\Marshal\Unpacking\T8\U4\somefile??a.
    9672 17:11:14.652 Processing DeadLetter rules.

Causes:

  • Repeated errors in file type identifications can arise if a file is not automatically deleted from the unpacking folder.

Resolution:

To resolve this issue:

  1. Stop the Controller and Engine services.
  2. Manually delete all the files from the T[\d] directories.
  3. If a particular file cannot be deleted (in particular if the file name ends with . or contains unprintable characters) you can issue the following command from the Windows command line only:

    Del "\\?\d:\marshal\unpacking\t8\4\filename"
     
  4. Start the Controller and Engine services.
  5. Repeat the steps for each affected processing server. 

 


Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle20306.aspx