SQM - Server Too Busy


This article applies to:

  • Trustwave SEG
  • Spam Quarantine Manager 

Question:

  • Why am I receiving the message "Server too busy" when accessing the SQM (SpamConsole)?

Symptoms:

When attempting to access the Spam Quarantine Manager you see a server error page with a "Server too busy" message.  Other websites within IIS display correctly (possibly including the SEG Admin Console).

Cause:

This issue has been observed when Anti-Virus is scanning files used by this website.

Resolution:

Option 1

Exclude the following directories from Anti-Virus scanning:

  • C:\Windows\Microsoft.NET\Framework*
  • The SpamConsole Install Directory, by default %SystemDrive%\Program Files (x86)\Marshal\MailMarshal Web Components\SpamConsole
    • For 32 bit servers, see the 32 bit Program Files location.

Option 2

If you would prefer not to change the Anti-Virus configuration, the following alternative has also resolved the issue in the field:

  1. Navigate to the SpamConsole install location as above.
  2. Back up the web.config file to a safe location.
  3. Edit the web.config file.
  4. In the system.web section, httpRuntime element, add a value delayNotificationTimeout="20" as follows:

    <system.web>
            <httpRuntime delayNotificationTimeout="20" />
    </system.web>
  • NOTE: Other values may be present in the system.web section and in the httpRuntime element.
    • If other values are present, DO NOT change them, but add the new value or new line as required.

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle20264.aspx