Reports show no usage or inconsistent data


This article applies to:

  • WebMarshal
  • Marshal Reporting Console

Symptoms:

  • The Web Usage by User report shows many site visits and bandwidth consumed in a period, but zero sessions and zero browsing time.
  • URL Browsing by User shows "No data available" for the same period.

Causes:

  • The "URL Browsing by User" report only includes data from full sessions.
  • Browsing time calculations require session data.
  • If a page or applicationĀ keeps a session open for long periods of time then the session will continue over multiple days. You can confirm the state of sessions by looking at the SessionLog table in the WebMarshal database.
  • For example, Office365 if left running will keep a session open.

Resolution:

To report on session data, choose a longer period that includes both the start and finish times of the session.

Note:

If necessary you can forcibly close all sessions by reloading WebMarshal configuration. This action should not be performed often because it consumes resource and affects user experience.


Last Modified 6/5/2014.
https://support.trustwave.com/kb/KnowledgebaseArticle19425.aspx