Virus and spam reporting and statistics not working


This article applies to:

  • Trustwave MailMarshal (SEG) 6.9 or above  

Symptoms:

  • Virus overview reports do not show any data
  • For some upgraded systems, spam overview reports show incomplete or no data
  • The "Threats and malicious content" dashboard category shows incomplete or no data
  • Deadletter actions cause looping behavior in the Engine

Causes:

  • Dead Letter folders were added to the configuration at version 6.9.
    • The names of the dead letter folders can conflict with the names of default folders used for spam and viruses.
    • The names of the dead letter folders can conflict with names of classifications.
  • The overview reports and dashboard items depend on the count of messages moved or copied to named folders, as recorded in the database.
  • Messages could be logged incorrectly in the database.

Resolution:

To resolve this issue for logging of future messages, do not use standard folders named "Virus" or "Spam". Do not use classifications named "Virus" or "Spam".

  • You can rename the existing folders and/or classifications, or create new folders and/or classifications.

For instance you could rename these items as "Spam messages" and "Virus messages".

  • Note that recent versions of MailMarshal do not create a folder named "Spam" by default, but installations upgraded from older versions might have a folder with this name.
  • If you choose to create new folders, remember to add the new folders to the appropriate Reporting Groups.

Last Modified 5/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle15988.aspx