This article applies to:
- Trustwave ECM/MailMarshal Exchange (MailMarshal Exchange) 7.0 through 7.1.1
Symptoms:
- Queues folder location on a processing server (node) was changed using Server Tool
- The Incoming, ProcessedOK, and Sending queues continue to use the default location
Causes:
- The software incorrectly sets and reads these values in Registry.
Resolution:
To resolve this issue, upgrade to version 7.1.5 or above. This issue was fixed in version 7.1.5.
- Note: If you move the Queues folder, you must grant full control over the new folder to the Network Service account used by the Exchange Agent.
Workaround:
If you cannot upgrade immediately, you can manually set locations. On each affected server, edit the Registry and set the locations for these folders as required.
- Open Regedit.
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Marshal\MMExchange\Node\Directories
- Among other values in this key you should find the string values Incoming, ProcessedOK, and Sending
- Update each of these values with the desired absolute path, for example, as in the screenshot:
- From the MailMarshal Exchange Configurator, commit configuration, and then restart the MailMarshal Exchange services on the affected server.
Notes:
- As always, take due care when editing the Registry. Trustwave recommends you back up the registry before making changes.
- With the affected versions, each time you use the Server Tool to change this location, you will need to repeat the above procedure.