Engine and Array Manager stopping issues with MailMarshal 6.9.6 and 6.9.7


This article applies to:

  • Trustwave MailMarshal (SEG) 6.9.6 and 6.9.7

Symptoms:

  • Engine stops when processing some messages with documents attached
  • Array Manager stops when the subject messages are viewed in the Console

Causes:

  • The MailMarshal 6.9 Engine does not correctly handle specific features found in some OLE documents. This problem can also affect viewing of messages because the content must be handled by the Engine to be viewed.

Resolution:

Upgrade MailMarshal to the latest version. These issues were first fixed in 6.9.8.3800, released November 3, 2011.

Notes:

To avoid the issue with the Array Manager, do not use the Console message viewer to open deadlettered messages that have attachments. You can take other actions on these messages as normal (such as releasing and forwarding).


Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle14354.aspx