Some web sites do not load, or load very slowly


This article applies to:

  • WebMarshal
  • Microsoft Windows Server or Workstation

Symptoms:

  • One or more sites time out when using the WebMarshal proxy, but they load fast when not using WebMarshal
  • WebMarshal is installed on Windows Server 2008 or above (or related Workstation OS)
  • The behavior is not changed by adding the sites to the bypass list, disabling all connection rules, or disabling the cache
  • WebMarshal on Windows 2003 server in the same LAN works well
  • In a packet capture it appears that the sites refuse or reset the connection

Causes:

  • This issue could be caused by the "TCP auto tuning" feature of networking in recent Windows operating systems.
  • Auto-tuning is known to cause communication issues when used with devices that do not support auto-tuning. The Microsoft article (referenced below) states in part:

    "When the Receive Window Auto-Tuning feature is enabled for HTTP traffic, older routers, older firewalls, and older operating systems that are incompatible with the Receive Window Auto-Tuning feature may sometimes cause slow data transfer or a loss of connectivity."

Resolution:

To disable TCP Auto-tuning:

On the WebMarshal node server(s), open an elevated command prompt and run the command:

netsh int tcp set global autotuninglevel=disabled

Notes:

For more details of the auto-tuning functionality, see the following Microsoft Knowledge Base article:   http://support.microsoft.com/kb/947239



Last Modified 10/26/2011.
https://support.trustwave.com/kb/KnowledgebaseArticle14343.aspx