MailMarshal SQM failed to authenticate the user ‘Domain\User'


This article applies to:

  • Trustwave MailMarshal (SEG) Spam Quarantine Management website
  • Trustwave ECM/MailMarshal Exchange 7.X Quarantine Management website

Symptoms:

  • If you rename an Active Directory user account, the user is unable to log into the MailMarshal SQM or QM website.
  • For example:
    • The Active Directory account 'Testuser1' is renamed to 'Testuser2'. 
    • When this user attempts to log on to the MailMarshal website they receive the following error: MailMarshal SQM failed to authenticate the user ‘Domain\Testuser1', if the problem persists contact your Administrator

Cause:

This issue is caused by caching of the Windows Authentication credential at the server.

  • Note: Changing the credential will also cause an issue with user aliases. The user will not see their personal content once logged on. To fix this separate issue, see Trustwave Knowledgebase article Q10003.

Resolution:

To clear the cached credentials, restart Windows on the web server.

Before restarting Windows, you can try the following actions which are less disruptive.

  • Wait for a period of time without attempting to use the account for this connection, to allow the cached credential to time out.
  • Clear the authentication cache at the client.
  • Restart IIS on the web server.

      Last Modified 3/1/2020.
      https://support.trustwave.com/kb/KnowledgebaseArticle14228.aspx